Dfdebugtrackerchen

Aus DebianforumWiki

Wechseln zu: Navigation, Suche

Neue Bugs bitte unten bei "offen" mit Kurzbeschreibung eintragen, in Klammern angeben, wer zuständig ist oder daran mitarbeitet, Details und Diskussion dann weiter unten als eigenes Topic. Zähler inkrementieren


Inhaltsverzeichnis

Wer macht was

eggy: in der Sonne liegen

TRex: git anlegen

niemand: beobachten

Was muss noch gemacht werden

Bugs

offen

Bug 0 alles toll?

  • nee leider noch nicht

Bug 3 (alle) neue Bugs

  • gefundene Bugs unten als neuer Bug eintragen

Bug 6 () Plugin-Bug: No Paste

Bugs in Plugin: NoPaste (tlw. OK; Plugin für phpBB 3.1.x läuft so lala)

  • was ist mit "so lala" gemeint?

Bug 8 (jemand der mit der wikisyntax besser klarkommt) Bugtracker aufräumen

Jemand könnte das hier mal schöner machen ;)

Bug 12 () JS notwendig

JS ist nun notwendig, um das Forum sinnvoll nutzen zu können (lässt sich wohl nicht abstellen, aber wollte es mal angesprochen haben)

Das kann ich (Meillo) nicht nachvollziehen. Mit w3m (was kein JS kann) sieht das Forum aus wie davor und bedient sich wie davor. Man kann es lesen, posten, suchen, etc. (Moderationstools oder so Zeugs habe ich nicht getestete.) (Im Firefox habe ich fuer das DFDE aber schon seit langem JS freigeschaltet, kann aber nicht mehr sagen wieso.)

eggy: Bei mir ist alles was ich getestet hab auch ohne js ok, ausser einige emojis (bug 35)

Bug 16 (feltel/eggy) Vervollstaendigung der englischen Spracheinstellung

Bislang ist das Forum weiterhin zu 60% deutsch wenn man auf Englisch umstellt.

  • Ist "Absicht" (aka Faulheit) - eggy: wir sollten en komplett deaktivieren, gibts Gegenargumente?
    • Pro EN-Abschalten:
      • für Leute die überhaupt kein Deutsch verstehen bringt das Forum eh nix (eggy)
      • ersparrt uns die Arbeit mehrere Sprachversionen zu pflegen (und zu testen) (eggy)
      • Waere fuer mich tragbar (Meillo)
    • Contra EN-Abschalten:
      • Bei Softwareprojekten sind die englischen Meldungen meist verstaendlicher und klarer als die uebersetzten, darum verwende ich Software in der Regel auf englisch. (Meillo)
      •  ?
    • Pro Ignorieren:
      • Kann man nachrüsten, stört uns jetzt nicht. (TRex)

Bug 20 () Banner zu gross

Der neue Banner nimmt ziemlich viel Platz weg. Natuerlich sieht er so gut aus, aber fuer die Benutzung des Forums nimmt er nur Platz weg.

  • Ich (Meillo) bin dafuer, dass wir hier die Prioritaet zugunsten der Nutzung verschieben.
    • @Meillo: der swirl und "debianforum.de ..." oder noch was anderes ?
    • @eggy: Die Hoehe dieses Blocks. Da sind nur Swirl, Name und Suchschlitz drin, nimmt aber viel vertikalen Platz weg. Der Block darunter koennte auch noch ein bisschen komprimiert werden. Das wuerde halt mehr vertikalen Platz fuer den eigentlichen Inhalt schaffen. Diese Bannerinformation schaut 90% der Nutzer sowieso nie an.
  • Auf einem Telefon bricht es recht kreativ um "debianforum.d /n e " ... etwas kleiner würde da wohl etwas weniger lustig aussehen (eggy) <- jetzt besser (git)

Bug 31() Mehrere Markierungen mit Tags versehen

Beim Editieren von Einträgen im Forum konnte ich imho früher mittels STRG+ Maus mehrere Abschnitte markieren und dann Codetags mittels der kleinen Knöpfchen einfügen. Es ist freilich möglich, dass ich mich täusche und das wo anders (andere Foren/Wikis) so war, auf jeden Fall geht das nicht (mehr). Ggf. siehe vorne halt ein NOFIX.

Bug 35 () Emojis zu groß

Emojis zu groß und nicht "größenverstellbar", siehe https://debianforum.de/forum/viewtopic.php?p=1137975#p1137975 eggy: das Zeug wird von jsdelivr.net nachgeladen (wenn man js blockt, gibts entweder s/w symbole oder garnix zu sehn) - wenn man das rauspatched, was ich gut fände - remote js nachladen ist doof, dann sind halt alle emojis "klein" - dh man erkennt die unterschiede unter umstaenden nicht - vorschläge?

  • egal. weg damit
  • weg damit. aber mehr smilies anbieten
  • das js ansehen und evtl lokal anbieten (eggy: waer mir zu aufwaendig)
  • ...

@Meillo: magst Du mal testen, wie das in Deinen Textbrowsern aussieht? ( http://aero2k.de:8080/phpBB3/viewtopic.php?f=2&t=3#p3 )

Meillo: Mit w3m sieht's wie immer aus, weil man da eh keine Bilder sieht. ;-) Aber mit deaktiviertem JS im grafischen Browser sieht man auf den Buttons keine Icons, bloss nicht darstellbare Unicode-Zeichen. Ich wuerde mir dort statische Bilder wuenschen.

Bug 40 () zuviel Blau

  • Mausover bei Links
  • Rand des Texteditfelds bei Reply
  • Beitragsseitenzahlen
  • Onlineband am Avatar
  • "Optionen" (unterhalb vom Antwortfeld)

Bug 42 () ist die Antwort

Aber wie war nochmal die Frage?

Bug 43 () Seitennr zu tief

Anzahl der Beitragsseiten ist zu tief (in der Threaduebersicht), im git gefixt (hat aber evtl was anderes kaputtgemacht)

Bug 47 () Beitragsicons bei geringer Breite (...) unanklickbar

Bei kleinerer Breite rutschen die Icons zu drei Punkten zusammen, die aber nicht anklickbar sind (Folgefehler von Bug 30?)

Bug 48 () Benachrichtigungsmail + Bearbeitungslink

Der Bearbeitungslink in der Benachrichtigungsmail

https://debianforum.de/forum/viewtopic.php?f=AA&t=XXXXX&p=YYYYY&e=YYYYY ist/war falsch und wurde verbessert.

Mit jetzigen Links

https://debianforum.de/forum/viewtopic.php?f=AA&t=XXXXX&e=1&view=unread#unread

springt der Browser (nach einmaliger Benutzung) nur zum Threadanfang. Es sollte imo sein

https://debianforum.de/forum/viewtopic.php?f=AA&t=XXXXX&p=YYYYY#pYYYYY oder

https://debianforum.de/forum/viewtopic.php?f=AA&t=XXXXX#pYYYYY

um dauerhaft direkt zum zum Zeitpunkt der Mail aktuellen Beitrag zu springen.

Bug 49 () url-tag schützt den Link nicht mehr

Ein langer Beispielpfad

https://eine.adresse/laengerer/pfad/laengerer/pfad/laengerer/pfad/laengerer/pfad/

Ohne tag wird gekürzt

https://eine.adresse/laengerer/pfad/lae...erer/pfad/ , ok.

Mit url-tag wird im Gegensatz zu früher aber auch gekürzt

https://eine.adresse/laengerer/pfad/lae...erer/pfad/

Selbiges Verhalten zeigt sich auch in den Foren auf phpBB.com, ergo nehme ich an, das diese Art Linkverkürzung eine gewünschte Funktion von phpBB 3.2 ist. Konfigurierbar ist es im Admin-Panel jedenfalls nicht. (feltel)

Bug 53 (eggy) Links werden nicht umbrochen, verhindern scrollen

in der aktuellen verwendeten Version (nicht HEAD) kommt es zu "kann nicht seitwaertsscrollen-Fehlern wenn es in der mobilversion einen langen Link etc gibt. FIX: float:right von .page-body wegnehmen, flex tut trotzdem

apropos flex: nochmal umbauen (ich hab ne idee komm wahrscheinlich aber erst fr/sa dazu das zu testen, sorry)

Bug 55 () Mobile Ansicht

Eine Mobile Ansicht fehlt. Im senkrechten halten des Smartphones erscheint die Naviagation ganz unten, im waagerechten halten erscheint die Navigation zwar, dabei ist dann aber der Titel Willkommen zu Breit.

Ab einer gewissen geringen Auflösung sind die Beiträge nicht mehr zu lesen. Es ist nur noch ein Ausschnitt der tatsächlichen Breite zu sehen. Z. B. die rechte Hälfte. Screenshot Abgeschnittene Thread-Ansicht. Vergrössern/Verkleinern derzeit nicht möglich. Auch keine Bildlaufleisten um nach links zu scrollen. (Heisenberg)

@heisenberg: wir haben im git nochmals was geaendert, sollte nach dem naechsten update besser sein (eggy)

Bug 56 () Ueberlappender Seitenzaehler bei bestimmten Bildschirmbreiten

In Uebersichten (z.B. neue Beitraege) kann es bei manchen Bildschirm/Browserbreiten zu Ueberlappung der Auflistung der Seitennummern mit der Anzeige der Metadaten (Threadersteller, Datum/Uhrzeit, Unterforum) kommen.

Screenshot

Zustaendigt scheint die common.css (ab Zeile 948):

.row .pagination {
    display: block;
    margin-top: -0.8em;
}

Bug 57 (feltel) NoPaste: Kopierbarer BBCode fehlt

Im alten Theme gab es bei NoPaste-Einträgen unterhalb des Pastes vorformatierte BBCodes, die in ein Forumsposting eingefügt werden konnten und direkt auf das entsprechende Paste verwiesen.

Bug 58 () icon-red

Wenn man eingeloggt ist, wird an einigen stellen doch noch icon-red bei neuen Postings benutzt, nicht icon-debianforum_unread wie gewünscht.

Bug 59 () An/Abmelden

guennid: Wenn ich beim Schließen des der DF-Seite oder des Browsers die Abmeldung im DF vergessen habe, müsste ich mich, auch wenn ich das DF sofort wieder aufrufe, wenn ich denn wollte, neu anmelden. Im unteren Teil der Startseite ("Forenübersicht" hat mir besser gefallen) werde ich aber nach wie vor als angemeldet geführt.

Bug 60 () NEXT FREE BUG NUMBER

Dies ist der Platzhalter, damit man weiss welches die naechste freie Bugnummer ist. Um einen neuen Bug einzutragen, diese Nummer verwenden und die Nummer des Platzhalters inkrementieren.

Galerie

Bug 5 () Plugin-Bug: Galerie

  • Bugs in Plugin: Galerie (Entwicklung eingestellt, ähnliches Plugin wohl nicht vorhanden),
    • Ein aktiver Fork scheint allerdings vorhanden, Tauglichkeit muss evaluiert werden
  • Falls Alternativlösung benötigt
    • Was machen wir mit dem alten Daten? behalten? (eggy: dafuer, catdog2: dafür)
      • Pro behalten: Uns gehen uns einige Threads inhaltlich kaputt wenn wir die URLs ändern, URL könnte man aber per Skript reparieren oder per rewrite-rule anpassen.
    • Hat jemand eine Empfehlung die folgende Features kann:
      • selbe Struktur für einfache Migration, d.h. Unterstützung von mindestens einem (?) Level Untergalerien (TRex)
      • Integration mit Forum wünschenswert, aber vermutlich zu kompliziert/teuer in der Wartung (1. direkter upload aus dem Forum, 2. BBCode zur einfachen Integration hochgeladener Bilder - das können zwei weitere Stücke Code sein, die aber niemand haben will!) (TRex)
      • PHP7

Bug 23 (eggy) Galerie: Fehler im CSS

https://debianforum.de/forum/gallery Komisches Muster im Galerie-Balken: class="row-item" ist falsch (muesste icon oder so sein), eggy will das noch global ändern (todo)

Bug 24 () Galerie css kaputt Teil 2

https://debianforum.de/forum/gallery/search/self


noch offen betreffen aber nicht das Theme

Bug 19 () Forensuche zeigt Beitraege statt Threads

Das sei bisher anders gewesen. eggy: Sieht doch aus wie immer - denk ich, kann mich irren.

Es ist 'ne Lapalie, aber mich nervt's. Es geht nur um die default-Einstellung. Bisher war es so, dass, wenn man seine Suchbegriffe eingegeben und die Suche gestartet hatte, defaultmäßig die Threads, also die Themen, aufgelistet wurden, in denen die Suchbegriffe gefunden wurden. Wollte man die Einzelbeiträge sehen, in denen der Suchbegriff auftauchte (möglicherweise ganz viele in einem der schönen Monsterthreads unter "Smalltalk"), dann musste man das extra anklicken. Ich konnte damit noch nie was anfangen. Mich wundert, dass die Änderung des default-Verhaltens niemand auffällt. Bin ich vielleicht der Einzige, der die SuFu nutzt? :-)

Ich hab mal in der Live-Seite testweise die Suchfunktion so angepasst (@eggy: overall_header.html; input type hidden) , das die Suchergebnisse nicht als Beiträge sondern als Themen angezeigt werden. Das war im Code von phpBB 3.0.x bei uns auch so. Wenn kein Contra kommt, das würde ich das so ins GIT übertragen. --Feltel (Diskussion) 18:46, 16. Jul. 2017 (CEST)

Bug 32 () Link hinter Titel in Threadansicht

Wie kann man den Link zum Thread kopieren wenn man sich auf einer Seite > 1 befindet? Bislang ging das IIRC ueber den Titel, der immer auf die erste Seite verlinkt hat. Jetzt verlinkt der Titel auf die Seite selbst (was keinen Nutzen bringt). Wenn ich den Link zum Thread kopieren will, dann geht das nur ueber die Seitenzahl. Mein Vorschlag ist, dass wir den Threadtitel auf den Threadanfang verlinken, falls das ohne Eingriffe in den PHP-Code moeglich ist. --Meillo

Bug 38 () Benachrichtigungs-Mail-Spam

Hat man im Foren-Profil eingestellt, dass man bei Antworten auf ein beobachtetes Thema eine E-Mail bekommen möchte, so bekam man früher genau eine Mail, bis man das Thema das nächste mal angemeldet angeschaut hat. Nun bekommt man bei JEDER Antwort eine E-Mail, unabhängig davon, ob man sich das Thema zwischendurch angemeldet angeschaut hat. Das führt mitunter dazu, dass man nach "längerer" Abwesenheit (z.B. über Nacht) einen ganzen Sack voll neue Mails hat, wo eine ausreichen würde. Hikaru (Diskussion) 08:26, 7. Jul. 2017 (CEST)

passiert nur wenn die foreninterne Benachrichtigung deaktiviert ist, während E-Mail-Benachrichtigung aktiv ist. Das Problem ist als phpBB-3.2-Bug bekannt: https://debianforum.de/forum/viewtopic.php?f=14&t=165910&p=1138256#p1138251 Hikaru (Diskussion) 16:12, 8. Jul. 2017 (CEST)

Bug 51 (feltel) RSS-Feed-Fehler

Der RSS-Feed des Forums läuft bei aktivierter phpBB-URL-Kürzung (/forum/app.php/feed -> /forum/feed) nicht. Browser bricht Laden mit Too many redirects ab. Bei Aufruf über URL /forum/app.php/feed/ läuft der Feed. Andere Extensions laufen auch mit aktivierter URL-Kürzung ohne Probleme. 2. Fehler das immer nur Foren-übergreifender Feed angezeigt wird, trotz entsprechend passender Foren-spezifischer Aufrufparameter.

gelöst

  • 1 (Feltel): Test der Datenübernahme von phpBB 3.0.x zu 3.2.x

Die Migration läuft mittlerweile sauber durch, so das keine Informationsverluste beim Upgrade zu erwarten sind. Ein paar Usereinstellungen müssen im Nachgang angepasst werden, aber alles überschaubar.

  • 2 (Feltel) : Template testen: Das von Eggy entwickelte Template läuft, auf den ersten und zweiten Blick sind nur wenige Bugs sichtbar.
  • 4 (Feltel) : Bugs in Plugin: MediaWiki-Userintegration/Bridge (OK, gibt es in neuer Version)
  • 7 (Feltel) : Bugs in Plugin: Tapatalk (OK, gibt es in neuer Version)
  • 9 () : Threadicons durcheinander: vermutlich durchs theme-reboot gelöst
  • 10 (feltel) [tt]-BBCode wird nicht richtig angezeigt. -> Durch neue Theme-Version gefixt.
  • 13 (eggy) : Linkfarben sind nun wieder debianrot.
  • 14 (Feltel) : reCaptcha kaputt; Template-Fix hat geholfen. Danke eggy. :-)
  • 17 () Zu kleine Schrift, verhältnis sollte jetzt ok sein, wems noch zu klein ist: browserzoom (oder neuen bug mit konkreten vorschlaegen aufmachen)
  • 18 () Fehlender Name bei namentlichen Zitaten: Es erscheint kein Name, trotzdem man mit [ quote="name" ] zitiert.
  • 21 (eggy) Benachrichtigung bei neuer PM, jetzt gut sichtbar
  • 26 () : Threadicons grün: vermutlich durchs theme-reboot gelöst
  • 27 (eggy): klickbares Logo ist wieder klickbar und fuehrt wieder auf die Startseite
  • 28 () : Code-Tags haben Zeilenumbrüche.
  • 29 (eggy): Unvollständiges Popup-Menu beim "Schraubenschlüssel" am Threadende sieht wieder vollständig aus
  • 33 (feltel): Tapatalk-Banner und -PopUp entfernt
  • 36 (meillo) PM Symbole in den Userboxen fehlen. Durch Theme-Update gefixt.
  • 37 () [tt]-Tag erzeugt Zeilenumbrüche, durch Theme-Update gefixt
  • 39 () quote go-up-pfeil ist nicht gut sichtbar; mit Theme-Update behoben
  • 41 () das AUGE; durch Bugfix 50 ebenfalls behoben
  • 44 () iconloser Knopf ("Schnellzugriff") in der Galerie siehe Pfeil im Screenshot: https://debianforum.de/forum/app.php/gallery/image/608/medium
  • 46 (tintom) Galeriesymbol hat falsche Position: Das Symbol (s. Bug 41) ist nun am äußeren rechten Rand neben dem Benutzernamen; Mit Bugfixes 41+50 behoben
  • 50 (eggy) Navileiste aufräumen: in Extension-spezifischem Template ext/phpbbde/pastebin/styles/debianforumde/template/event/overall_header_navigation_append.html deaktiviert
  • 52 (Tintom) Benutzername [TAB] Passwort funktioniert nicht mehr -> funktioniert wieder
  • 15 (eggy): Zebrafarben gegen schwache Trennung zwischen Posts in Threadansicht eingebaut
  • 22 (eggy): Linke Leiste hat jetzt keine fixe Breite mehr
  • 34 (eggy): Suchbox größer damit "Diese Ergebnisse durchsuchen reinpasst"
  • 30 (eggy): Buttons am Beitrag in schmaler Ansicht scheinen ok zu sein
  • 45 (eggy): untere Leiste gefixt
  • 11 (eggy): Quote Blöcke sehen für mich ok aus (git master); falls doch nicht, bitte mit Screenshot wieder eintragen
Meine Werkzeuge